Gravação no sonar com problemas

Ir em baixo

Gravação no sonar com problemas

Mensagem por Eliabass em Qua Set 22, 2010 1:31 pm

ola galera do forum, estou com um probleminha que esta tirando meu sono, comprei a pouco tempo atraz um placa de audio externa chamada Cakewalke UA4FX e estou fazendo pequenas gravações com ela, mas no momento da gravação da alguns estalos ou uma pequena travada que atrapalha a gravação, ou quando coloco algum audio pra gravar junto da a mesma coisa, eu uso o program Sonar 8, queria saber se tem alguma configuração que estou fazendo errado no sonar ou na placa, se puderam me dr uma força neste problema agradeço
avatar
Eliabass
Membro

Mensagens : 138
Localização : Serra-ES

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Alexandre Lopes em Qua Set 22, 2010 1:41 pm

Elias, faz muito tempo que não mexo no sonar ...

Você fala os dropout ?

Qual a configuração do seu PC ?

Qual o sistema operacinal ?

No momento da gravação, o grafico do uso do disco / processamento, fica na casa de quantos % ?

avatar
Alexandre Lopes
Membro

Mensagens : 1213
Localização : São José do Rio Preto - SP

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Qua Set 22, 2010 2:35 pm

Dropout é quando o processador+cache não dão conta de gerenciar os sinais de entrada e processar plugins em tempo real... aí acontece o drupout, mas trava tudo e a gravação/reprodução pára!

Como citou o Alexandre, pra um disgnóstico mais preciso, é necessário saber detalhadamente a configuração da máquina.

Num primeiro momento, recomendo que procure no Sonar as configurações de tamanho de Buffer (tem isso aqui no Fórum... triplique o valor atual)... e também interrompa a execução de programas em background como anti-vírus e afins... evite ao máximo a concorrência de acesso à disco e memória quando estiver gravando!
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Eliabass em Qui Set 23, 2010 8:31 am

minha maquina é um notebook ( isso tem a ver ? ) Windowns 7, 4Gb de memoria , 320gb de HD, Processador Dual Core intel, tem que falar mais algo ? qualquer coisa so falar
avatar
Eliabass
Membro

Mensagens : 138
Localização : Serra-ES

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Qui Set 23, 2010 9:44 am

Bem, com essa configuração você não deve ter problemas de dropout... dessa forma, verifique duas coisas:

1 - Aumente os valores de Buffers nas configurações de áudio do Sonar;

2 - Veja se existem muitos programas acessando a memória da máquina de forma concorrente, como anti-vírus e afins!

O disgnóstico "estalos com pequenas travadas", em 99% dos casos está relacionado ao tamanho do Buffer. Dá uma olhada na imagem do link abaixo:

http://www.ixbt.com/multimedia/creative/extigy/sonar-wdm.png

avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Sex Out 29, 2010 11:44 pm

Help, Claudião!

Depois de preparar a máquina nova aqui (Core i7-950 + 6 Gb RAM + Intel DX58SO + Creative X-Fi + Delta-66), reinstalei os programas antigos sob o Windows 7 x64.
Instalei o Sonar 8.5, fiz os upgrades, instalei os plugins todos, fiz o reconhecimento deles no Sonar e fui testar a bagaça aqui!
Maior decepção! Pluguei a guitarrinha na Delta-66, coloquei os fones e comecei a gravar!
Quando cliquei no STOP, a track gravada ficou com a metade do tamanho e o som que saui dela foi a coisa mais estranha que eu já ouvi!
Como se tivesse esquecido trechos da gravação. Como se a cada segundo de gravação, 0,5 s tivesse sido apagado!
Tentei WASAPI e MME32 tb, sendo que este último foi o que apresentou o resultado menos pior.
Mudei o driver WDM pra ASIO, mas o Sonar diz que o ASIO4ALL está desconectado.
É muito estranho... Vou ver se acontece a mesma coisa no Acid Pro, mas isso é muito esquisito!
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Sab Out 30, 2010 12:04 am

Andrezinho,

Na minha opinião, o problema está no conflito entre os drivers da X-Fi e Delta, causado pelo próprio Windows.

Como o Windows reconhece de forma nativa (plug and play) os periféricos da Creative, ele vai sempre tomar a X-Fi como device padrão para qualquer coisa relativa a áudio. Dessa forma, o Windows está forçando a barra para que a Delta utilize os drivers da Creative X-Fi, e oo resultado disso é essa coisa "torta" que você está ouvindo, e a instalação do ASIO foi a peça que faltava pra completar a bagunça!

Minha dica é: remova *todos* os drivers de áudio da sua máquina, inclusive o ASIO... em seguida, reinstale *somente* os drivers da Delta. Certifique-se em baixar os drivers da Delta que sejam compatíveis com o Windows 7-64, lá no site da M-Audio tem. Promova também uma limpeza no registro do Windows, remova tudo que tiver a palavra chave "Creative X-Fi"..., remova inclusive a própria placa X-Fi do slot... dê um boot na máquina e proceda com a nova instalação da Delta.

Depois me fala se funcionou!
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Sab Out 30, 2010 12:55 am

É... Vou tentar fazer isso!
Mas o Acid Pro funcionou redondinho!
Se me encher muito o sacolé, vou ficar só com o Acid Pro e tentar fazer ele reconhecer os plugins todos...
Pobre sofre...
Se fosse rico, contratava um mané pra fazer pra mim!
kkkkkkkkkkkkkkkkkkkkkkkkkkkk
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Gomba em Sab Out 30, 2010 10:54 am

Não conheço nenhum mané que entenda de placas e interfaces de audio não...
avatar
Gomba
Membro

Mensagens : 5947
Localização : Niterói-RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Sab Out 30, 2010 12:08 pm

Nisso tu tá certo, Gomba!!! kkkkkkkkkkkkkkkkkk
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Dom Out 31, 2010 8:19 pm

E aí Andrezinho, conseguiu resolver o problema?
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Qui Nov 04, 2010 11:57 am

Claudião! Eu desinstalei o ASIO4ALL e tentei novamente. Os problemas persistiram.
Vou tirar a placa de som, reinstalar os drivers da Delta 66 e ver o que acontece. Mas ela não joga som pras caixas...
Por enquanto o AcidPro 7 e o SoundForge 10 estão funcionando redondinhos com latência muito próxima de zero...
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Qui Nov 04, 2010 12:44 pm

^ Quando você terminar a reinstalação, rode o wave Profile do Sonar, faça o seguinte:

-- Na guia "General"
1 - Certifique-se que "Playback timing" e "Record timing" estão utilizando rigorosamente a mesma interface... se isso não acontecer, cmo certeza vai gerar latência e atrasos!

2 - Trabalhe com "Audio driver bit depth" em 24 bits, e marque 64-bits Double precision engine

3 - Em "Sampling rate" trabalhe com o valor 44100.

4 - Dimensione Buffer Size de acordo com o sugerido pelo botão Wave Profile.

-- Na guia "Advanced"

1 - Desmarque as opções Enable Read Caching e Enable Write Caching

2 - Em "Driver Mode", use MDW/KS, esse é o melhor padrão, bem superior ao ASIO.

3 - Marque a opção "Share drivers with others programs"

4 - Marque a opção "use multiprocessing engine" (pra um i7 isso é fundamental)

5 - Marque a opção "MMCSS (Windows Vista)"... isso faz com que o SO trabalhe a 64 bits.

6 - Desmarque a opção "Play effect tail after stopping"

7 - Marque a opção "Allways open all devices"

8 - Marque a opção "Remove DC-offset during record", para que o Sonar passe a filtrar os ruídos provenientes de energia elétrica.

9 - Em Synchronization, selecione a opção "Full Chase Lock".

Se depois desses 9 passos você continuar com problemas, então utilize este último recurso aqui:

- Em "Record pre-allocate file", entre com o valor 600. Isso fará com que o Sonar pré-aloque um arquivo WAVE com 10 minutos de duração no seu HD. Essa pré-alocação trabalha com espaços contíguos de blocos. Se isso resolver o seu problema, significa que o seu HD está altamente fragmentado, e necessita passar por um processo de desfragmentação.

Tenta essas coisas aí e depois me fala.
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Qui Nov 04, 2010 1:05 pm

Boa... Vou brincar disso amanhã de manhã quando estiver em casa.
as o HD não deve estar muito fragmentado não! Foi formatado e reinstalado a pouco tempo...
Tomara que agora funcione!
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Seg Nov 22, 2010 8:31 pm

Apanhei, apanhei e apanhei...
Acabei desinstalando o Sonar e instalando de novo...
E o problema agora é outro: quando se tenta abrir qualquer arquivo vIa Sonar, ele TRAVA A MÁQUINA!!!
Congela tudo! Até pra rebootar, tem que desligar e religar no power...
Mó marrento esse troço de Sonar...
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Seg Nov 22, 2010 9:58 pm

^ Andrezinho.... pelo quadro que você está pintando, acredito que seu problema é relativo a hardware mesmo, alguma incompatibilidade de hardware está causando essa confusão toda.

Desde a época de Cakewalk que já fiz zilhões de instalações de Sonar, e só tive problemas uma única vez numa máquina com processador AMD e placa de som on-board... essa deu trabalho, mas foi a única... tive que baixar o clock do processador na bios e desabilitar a placa on-board, e assim mesmo não ficou 100%.
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Ter Nov 23, 2010 9:55 am

Pô... Mó maldade com a minha pessoa!!!

Minha máquina até que nem é ruim... kkkkkkkkkkkkkkkkkk

Hoje vou tentar instalar no notebook!
Engraçado é que no Acid Pro não acontece nada... Roda normalzinho!

Vou ver se brinco com as configurações aqui. O programa abre, mas não deixa abrir arquivo.
Será que é pq uso outro HD pra guardar os arquivos?
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Claudio em Ter Nov 23, 2010 10:14 am

Andrezinho escreveu:
Será que é pq uso outro HD pra guardar os arquivos?

Não... essa inclusive é a forma mais correta de se trabalhar... programas num HD e arquivos de dados em outro... desde que, claro, os HDs sejam internos... USB não vale!
avatar
Claudio
Membro

Mensagens : 15147
Localização : Rio de Janeiro - RJ

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Andrezinho em Ter Nov 23, 2010 10:18 am

É... São internos sim... Mas tenho um externo pra backup...
avatar
Andrezinho
Membro

Mensagens : 3330
Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Gravação no sonar com problemas

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum